summaryrefslogtreecommitdiffstats
path: root/modules/desktop/hyprland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/desktop/hyprland.nix')
-rw-r--r--modules/desktop/hyprland.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/modules/desktop/hyprland.nix b/modules/desktop/hyprland.nix
index 134d52f..678a97f 100644
--- a/modules/desktop/hyprland.nix
+++ b/modules/desktop/hyprland.nix
@@ -108,9 +108,6 @@ in {
config = lib.mkIf (hyprlandConf.enable) (lib.mkMerge [
{
- environment.variables.WLR_NO_HARDWARE_CURSORS = "1";
- environment.sessionVariables.NIXOS_OZONE_WL = "1";
-
home.packages = [
pkgs.killall
pkgs.wl-clipboard
@@ -142,6 +139,7 @@ in {
config.common.default = ["wlr" "gtk" "hyprland" ];
};
+ environment.sessionVariables.NIXOS_OZONE_WL = "1";
home.manager.wayland.windowManager.hyprland = {
enable = true;
xwayland.enable = hyprlandConf.xwayland;
@@ -196,7 +194,7 @@ in {
])
( lib.mkIf (config.modules.device.gpu == "nvidia")
[
- "GBM_BACKEND,nvidia"
+ "GBM_BACKEND,nvidia"
"__GLX_VENDOR_LIBRARY_NAME,nvidia"
"LIBVA_DRIVER_NAME,nvidia"
"NVD_BACKEND,direct"