summaryrefslogtreecommitdiffstats
path: root/modules/desktop/picom.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/desktop/picom.nix')
-rw-r--r--modules/desktop/picom.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/desktop/picom.nix b/modules/desktop/picom.nix
new file mode 100644
index 0000000..7afe2f0
--- /dev/null
+++ b/modules/desktop/picom.nix
@@ -0,0 +1,13 @@
+{ config, lib, pkgs, user, ... }:
+with lib;
+{
+ config = mkIf (config.xserver.enable) {
+ services.picom = {
+ enable = true;
+ settings = {
+ backend = "glx";
+ corner-radius = 10;
+ };
+ };
+ };
+}