summaryrefslogtreecommitdiffstats
path: root/programs/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'programs/zsh.nix')
-rw-r--r--programs/zsh.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/programs/zsh.nix b/programs/zsh.nix
deleted file mode 100644
index 03a096f..0000000
--- a/programs/zsh.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ config, pkgs, ... }:
-{
- home.packages = with pkgs; [
- inotify-tools
- ];
-
- programs.zsh = {
- enable = true;
- shellAliases = {
- ll = "ls -l";
- unixos = "sudo nixos-rebuild switch --flake /etc/nixos";
- uhome = "home-manager switch --flake /etc/nixos";
- watchfile = "/etc/nixos/programs/scripts/watchfile.sh ";
- };
- history = {
- size = 10000;
- path = "${config.xdg.dataHome}/zsh/history";
- ignoreDups = true;
- };
-
- oh-my-zsh = {
- enable = true;
- plugins = [ "git" "thefuck" "pass" ];
- theme = "dst";
- };
- syntaxHighlighting.enable = true;
- };
-}