summaryrefslogtreecommitdiffstats
path: root/systems/jontop/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/jontop/default.nix')
-rw-r--r--systems/jontop/default.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/systems/jontop/default.nix b/systems/jontop/default.nix
deleted file mode 100644
index 43ffcea..0000000
--- a/systems/jontop/default.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ inputs, config, lib, modulesPath, pkgs, ... }:
-
-{
- imports =
- [ # Include the results of the hardware scan.
- (modulesPath + "/installer/scan/not-detected.nix")
- inputs.nixos-hardware.nixosModules.lenovo-thinkpad-x220
- ./filesystem.nix
- ];
-
- boot.loader.systemd-boot.enable = true;
- boot.loader.efi.canTouchEfiVariables = true;
-
- boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
- boot.initrd.kernelModules = [ "i915" ];
- boot.kernelModules = [ "kvm-intel" ];
- boot.extraModulePackages = [ ];
-
- hardware.opengl = {
- enable = true;
- };
-
- hardware.bluetooth.enable = true;
- services.blueman.enable = true;
-
- programs.light.enable = true;
-
- services.fstrim.enable = true;
-
- nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
- hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-}