summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..6ab8771
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,13 @@
+{ pkgs ? import <nixpkgs> {} }:
+pkgs.mkShell {
+ name = "toi-dev";
+ buildInputs = with pkgs; [
+ gnumake
+ gdb
+ m4
+ bison
+ flex
+ texinfo
+ gcc
+ ];
+}