summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2024-03-11 21:40:28 -0400
committerJon Santmyer <jon@jonsantmyer.com>2024-03-11 21:40:28 -0400
commit50392995d6e7f3a10fb74bb2f9073a4790f8933c (patch)
treec89b067b3bacf35e092af5c31fb6e6a08921f31c /shell.nix
downloadjove-env-master.tar.gz
jove-env-master.tar.bz2
jove-env-master.zip
simple env with basic test init programHEADmaster
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..7905cf3
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,29 @@
+{ pkgs ? import <nixpkgs> {} }:
+pkgs.mkShell {
+ name = "jove-build-env";
+ hardeningDisable = [ "format" ];
+ buildInputs = with pkgs; [
+ # Library depends
+ gmp gmp.dev
+ isl
+ libffi libffi.dev
+ libmpc
+ libxcrypt
+ mpfr mpfr.dev
+ xz xz.dev
+ zlib zlib.dev
+
+ m4
+ bison
+ flex
+ texinfo
+
+ gcc
+ stdenv.cc
+ stdenv.cc.libc stdenv.cc.libc_dev
+
+ # Test suite
+ qemu_kvm
+ parted
+ ];
+}