summaryrefslogtreecommitdiffstats
path: root/hosts/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-29 20:41:27 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-29 20:41:27 -0400
commit0d1276915ca8cdd9b1b65f8c11832d0d598c49af (patch)
tree220e5750d034dfc89f54aa0d828c27e9ea7dc300 /hosts/default.nix
parent1f327873451b9617e305b4b97f83a1824574881d (diff)
downloadnix-config-0d1276915ca8cdd9b1b65f8c11832d0d598c49af.tar.gz
nix-config-0d1276915ca8cdd9b1b65f8c11832d0d598c49af.tar.bz2
nix-config-0d1276915ca8cdd9b1b65f8c11832d0d598c49af.zip
really add laptop host
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix20
1 files changed, 19 insertions, 1 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
index a5aace9..862cccf 100644
--- a/hosts/default.nix
+++ b/hosts/default.nix
@@ -1,4 +1,4 @@
-{ inputs, lib, nixpkgs, nixpkgs-unstable, nurpkgs, home-manager, stateVersion }:
+{ inputs, lib, nixpkgs, nixpkgs-unstable, nurpkgs, nixos-hardware, home-manager, stateVersion }:
let
system = "x86_64-linux";
pkgs = import nixpkgs {
@@ -29,4 +29,22 @@ in
}
];
};
+
+ jontop = lib.nixosSystem {
+ inherit system;
+ specialArgs = {
+ inherit inputs system pkgs-unstable nurpkgs nixos-hardware stateVersion;
+ user = "jon";
+ };
+ modules = [
+ { nixpkgs.overlays = [ nurpkgs.overlay ]; }
+ ./config.nix
+ ./jontop
+
+ home-manager.nixosModules.home-manager {
+ home-manager.useGlobalPkgs = true;
+ home-manager.useUserPackages = true;
+ }
+ ];
+ };
}