summaryrefslogtreecommitdiffstats
path: root/hosts/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
commitf819e30b03dffcf9e74af4b8552e4a8ab8f54c58 (patch)
treec05f4f1db738d6cd9d2824b5000c6afc3b1d61d1 /hosts/default.nix
parentd3bb6cbb4724bc8f18f72fa3fea3e65f73ae8d09 (diff)
downloadnix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.gz
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.bz2
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.zip
major reorganizing to seperate modules
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
new file mode 100644
index 0000000..a5aace9
--- /dev/null
+++ b/hosts/default.nix
@@ -0,0 +1,32 @@
+{ inputs, lib, nixpkgs, nixpkgs-unstable, nurpkgs, home-manager, stateVersion }:
+let
+ system = "x86_64-linux";
+ pkgs = import nixpkgs {
+ inherit system;
+ };
+
+ pkgs-unstable = import nixpkgs-unstable {
+ inherit system;
+ };
+
+ lib = nixpkgs.lib;
+in
+{
+ jonbox = lib.nixosSystem {
+ inherit system;
+ specialArgs = {
+ inherit inputs system pkgs-unstable nurpkgs stateVersion;
+ user = "jon";
+ };
+ modules = [
+ { nixpkgs.overlays = [ nurpkgs.overlay ]; }
+ ./config.nix
+ ./jonbox
+
+ home-manager.nixosModules.home-manager {
+ home-manager.useGlobalPkgs = true;
+ home-manager.useUserPackages = true;
+ }
+ ];
+ };
+}