summaryrefslogtreecommitdiffstats
path: root/hosts/jonbox/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
commitf819e30b03dffcf9e74af4b8552e4a8ab8f54c58 (patch)
treec05f4f1db738d6cd9d2824b5000c6afc3b1d61d1 /hosts/jonbox/default.nix
parentd3bb6cbb4724bc8f18f72fa3fea3e65f73ae8d09 (diff)
downloadnix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.gz
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.bz2
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.zip
major reorganizing to seperate modules
Diffstat (limited to 'hosts/jonbox/default.nix')
-rw-r--r--hosts/jonbox/default.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/hosts/jonbox/default.nix b/hosts/jonbox/default.nix
new file mode 100644
index 0000000..ce5f4a3
--- /dev/null
+++ b/hosts/jonbox/default.nix
@@ -0,0 +1,43 @@
+{ config, lib, pkgs, stateVersion, ... }:
+
+{
+ imports = [
+ ./hardware.nix
+ ../../modules/hardware/bluetooth.nix
+ ../../modules/virt
+ ];
+
+ #Boot options
+ boot = {
+ loader = {
+ systemd-boot = {
+ enable = true;
+ configurationLimit = 8;
+ };
+ efi.canTouchEfiVariables = true;
+ timeout = 5;
+ };
+ kernelPackages = pkgs.linuxPackages_latest;
+ };
+
+ #Unfree-packages.
+ nixpkgs.config.allowUnfreePredicate = pkg:
+ builtins.elem (lib.getName pkg) [
+ "nvidia-x11"
+ "nvidia-settings"
+ "nvidia-persistenced"
+ ];
+
+ #OpenGL
+ hardware.opengl = {
+ enable = true;
+ driSupport = true;
+ driSupport32Bit = true;
+ };
+
+ #X11 Server
+ services.xserver.videoDrivers = [ "nvidia" ];
+
+ awesome.enable = true;
+ mullvad-vpn.enable = true;
+}