summaryrefslogtreecommitdiffstats
path: root/hosts/jontop/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-29 20:38:26 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-29 20:38:26 -0400
commit1f327873451b9617e305b4b97f83a1824574881d (patch)
treed2b35b4fe800efb2b63ce1e99ea7a3bff0a184ec /hosts/jontop/default.nix
parentf819e30b03dffcf9e74af4b8552e4a8ab8f54c58 (diff)
downloadnix-config-1f327873451b9617e305b4b97f83a1824574881d.tar.gz
nix-config-1f327873451b9617e305b4b97f83a1824574881d.tar.bz2
nix-config-1f327873451b9617e305b4b97f83a1824574881d.zip
add laptop host
Diffstat (limited to 'hosts/jontop/default.nix')
-rw-r--r--hosts/jontop/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/hosts/jontop/default.nix b/hosts/jontop/default.nix
new file mode 100644
index 0000000..4e53279
--- /dev/null
+++ b/hosts/jontop/default.nix
@@ -0,0 +1,32 @@
+{ inputs, config, lib, modulesPath, pkgs, ... }:
+
+{
+ imports = [
+ ./hardware.nix
+ ../../modules/hardware/bluetooth.nix
+ ];
+
+ #Boot options
+ boot = {
+ loader = {
+ systemd-boot = {
+ enable = true;
+ configurationLimit = 8;
+ };
+ efi.canTouchEfiVariables = true;
+ timeout = 5;
+ };
+ kernelPackages = pkgs.linuxPackages_latest;
+ };
+
+
+ hardware.opengl = {
+ enable = true;
+ };
+
+ programs.light.enable = true;
+
+ awesome.enable = true;
+ mullvad-vpn.enable = true;
+}
+