summaryrefslogtreecommitdiffstats
path: root/modules/desktop/apps/games/steam.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2024-01-07 12:00:08 -0500
committerJon Santmyer <jon@jonsantmyer.com>2024-01-07 12:00:08 -0500
commit7b79203f54853733d4fae88943829d0e24e6e49f (patch)
treea352d199fad7453332b9308a6295164157729f27 /modules/desktop/apps/games/steam.nix
parent184bd30bcb303104a4981ac742d8f8961c5477e7 (diff)
downloadnix-config-7b79203f54853733d4fae88943829d0e24e6e49f.tar.gz
nix-config-7b79203f54853733d4fae88943829d0e24e6e49f.tar.bz2
nix-config-7b79203f54853733d4fae88943829d0e24e6e49f.zip
massive overhaul
Diffstat (limited to 'modules/desktop/apps/games/steam.nix')
-rw-r--r--modules/desktop/apps/games/steam.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/modules/desktop/apps/games/steam.nix b/modules/desktop/apps/games/steam.nix
new file mode 100644
index 0000000..50b5c62
--- /dev/null
+++ b/modules/desktop/apps/games/steam.nix
@@ -0,0 +1,34 @@
+{
+ config,
+ options,
+ lib,
+ pkgs,
+ ...
+}: let
+ gamesConf = config.modules.desktop.apps.games;
+ configDir = config.nixosConfig.configDir;
+in {
+ options.modules.desktop.apps.games = {
+ enable = lib.mkOption {
+ type = lib.types.bool;
+ default = false;
+ };
+ steam.enable = lib.mkOption {
+ type = lib.types.bool;
+ default = true;
+ };
+ };
+
+ config = lib.mkIf (gamesConf.enable) {
+ home.packages = [
+ pkgs.steam-run
+ ];
+
+ programs.steam = lib.mkIf (gamesConf.steam.enable) {
+ enable = true;
+ remotePlay.openFirewall = true;
+ dedicatedServer.openFirewall = true;
+ gamescopeSession.enable = true;
+ };
+ };
+}