summaryrefslogtreecommitdiffstats
path: root/modules/desktop/hyprland/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2024-01-01 10:57:38 -0500
committerJon Santmyer <jon@jonsantmyer.com>2024-01-01 10:57:38 -0500
commit184bd30bcb303104a4981ac742d8f8961c5477e7 (patch)
treee1d96fea09fce882decebc91ba1128652ada594c /modules/desktop/hyprland/default.nix
parent5897af1a6c355f77c78f342d1d6f070670d14a4c (diff)
downloadnix-config-184bd30bcb303104a4981ac742d8f8961c5477e7.tar.gz
nix-config-184bd30bcb303104a4981ac742d8f8961c5477e7.tar.bz2
nix-config-184bd30bcb303104a4981ac742d8f8961c5477e7.zip
several changes, hyprland
Diffstat (limited to 'modules/desktop/hyprland/default.nix')
-rw-r--r--modules/desktop/hyprland/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/modules/desktop/hyprland/default.nix b/modules/desktop/hyprland/default.nix
new file mode 100644
index 0000000..2acf5b6
--- /dev/null
+++ b/modules/desktop/hyprland/default.nix
@@ -0,0 +1,36 @@
+{ config, lib, pkgs, user, ... }:
+with lib;
+let
+in
+{
+ options = {
+ hyprland = {
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ };
+ };
+ };
+
+ config = mkIf (config.hyprland.enable)
+ {
+ environment.variables.WLR_NO_HARDWARE_CURSORS = "1";
+ environment.systemPackages = with pkgs; [
+ wayland
+ glib
+ wl-clipboard
+ wdisplays
+ hyprpaper
+ ];
+
+ programs.hyprland = {
+ enable = true;
+ xwayland.enable = true;
+ enableNvidiaPatches = true;
+ };
+
+ programs.waybar = {
+ enable = true;
+ };
+ };
+}