summaryrefslogtreecommitdiffstats
path: root/modules/desktop/rofi.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
commitf819e30b03dffcf9e74af4b8552e4a8ab8f54c58 (patch)
treec05f4f1db738d6cd9d2824b5000c6afc3b1d61d1 /modules/desktop/rofi.nix
parentd3bb6cbb4724bc8f18f72fa3fea3e65f73ae8d09 (diff)
downloadnix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.gz
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.bz2
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.zip
major reorganizing to seperate modules
Diffstat (limited to 'modules/desktop/rofi.nix')
-rw-r--r--modules/desktop/rofi.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/desktop/rofi.nix b/modules/desktop/rofi.nix
new file mode 100644
index 0000000..d5aba06
--- /dev/null
+++ b/modules/desktop/rofi.nix
@@ -0,0 +1,18 @@
+{ config, lib, pkgs, user, ...}:
+with lib;
+{
+ options = {
+ rofi = {
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ };
+ };
+ };
+
+ config.home-manager.users.${user} = mkIf (config.rofi.enable) {
+ programs.rofi = {
+ enable = true;
+ };
+ };
+}