summaryrefslogtreecommitdiffstats
path: root/modules/hardware/audio.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2024-12-07 11:28:56 -0500
committerJon Santmyer <jon@jonsantmyer.com>2024-12-07 11:28:56 -0500
commitbe25e99f89ea9c05483e05c104a8c520a030484d (patch)
tree80cb6de2e93b347ffed782d963717f59c3dff587 /modules/hardware/audio.nix
parentc2ac689be0b8a26b4b5ec118bc6bc9adcb55800a (diff)
downloadnix-config-be25e99f89ea9c05483e05c104a8c520a030484d.tar.gz
nix-config-be25e99f89ea9c05483e05c104a8c520a030484d.tar.bz2
nix-config-be25e99f89ea9c05483e05c104a8c520a030484d.zip
some changes
Diffstat (limited to 'modules/hardware/audio.nix')
-rw-r--r--modules/hardware/audio.nix22
1 files changed, 9 insertions, 13 deletions
diff --git a/modules/hardware/audio.nix b/modules/hardware/audio.nix
index 3ffa32a..a674597 100644
--- a/modules/hardware/audio.nix
+++ b/modules/hardware/audio.nix
@@ -23,22 +23,18 @@ in {
alsa.enable = true;
alsa.support32Bit = true;
pulse.enable = true;
+
+ wireplumber.extraConfig.bluetoothEnhancements = {
+ "monitor.bluez.properties" = {
+ "bluez5.enable-sbc-xq" = true;
+ "bluez5.enable-msbc" = true;
+ "bluez5.enable-hw-volume" = true;
+ };
+ };
};
user.extraGroups = ["audio"];
home.packages = [pkgs.pavucontrol];
- }
- (lib.mkIf (device.hasBluetooth) {
- home.configFile = {
- "wireplumber/bluetooth.lua.d/51-bluez-config.lua".text = ''
- bluez_monitor.properties = {
- ["bluez5.enable-sbc-xq"] = true,
- ["bluez5.enable-msbc"] = true,
- ["bluez5.enable-hw-volume"] = true,
- ["bluez5.headset-roles"] = "[ hsp_hs hsp_ag hfp_hf hfp_ag ]"
- }
- '';
- };
- })
+ }
]);
}