summaryrefslogtreecommitdiffstats
path: root/modules/terminal/kitty/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2024-01-07 12:00:08 -0500
committerJon Santmyer <jon@jonsantmyer.com>2024-01-07 12:00:08 -0500
commit7b79203f54853733d4fae88943829d0e24e6e49f (patch)
treea352d199fad7453332b9308a6295164157729f27 /modules/terminal/kitty/default.nix
parent184bd30bcb303104a4981ac742d8f8961c5477e7 (diff)
downloadnix-config-7b79203f54853733d4fae88943829d0e24e6e49f.tar.gz
nix-config-7b79203f54853733d4fae88943829d0e24e6e49f.tar.bz2
nix-config-7b79203f54853733d4fae88943829d0e24e6e49f.zip
massive overhaul
Diffstat (limited to 'modules/terminal/kitty/default.nix')
-rw-r--r--modules/terminal/kitty/default.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/modules/terminal/kitty/default.nix b/modules/terminal/kitty/default.nix
deleted file mode 100644
index 5e0a432..0000000
--- a/modules/terminal/kitty/default.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{ config, lib, pkgs, user, ... }:
-with lib;
-{
- config.home-manager.users.${user} = mkIf (config.xserver.enable)
- {
- xdg.configFile."kitty/theme.conf".source = ./themes/mocha.conf;
-
- programs.kitty = {
- enable = true;
- font = {
- name = "FiraCode Nerd Font";
- size = 12;
- };
- settings = {
- repaint_delay = 10;
- input_delay = 3;
- sync_to_monitor = true;
-
- remember_window_size = false;
- initial_window_width = 640;
- initial_window_height = 480;
- enabled_layouts = "*";
-
- tab_bar_min_tabs = 2;
- tab_bar_edge = "bottom";
- tab_bar_style = "powerline";
- tab_powerline_style = "slanted";
- tab_title_template = "{title}{' :{}'.format(num_windows) if num_windows > 1 else ''}";
-
- background_opacity = "0.8";
- };
- extraConfig = ''
-include ./theme.conf
- '';
- };
- };
-}