summaryrefslogtreecommitdiffstats
path: root/programs/tmux.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
commitf819e30b03dffcf9e74af4b8552e4a8ab8f54c58 (patch)
treec05f4f1db738d6cd9d2824b5000c6afc3b1d61d1 /programs/tmux.nix
parentd3bb6cbb4724bc8f18f72fa3fea3e65f73ae8d09 (diff)
downloadnix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.gz
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.bz2
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.zip
major reorganizing to seperate modules
Diffstat (limited to 'programs/tmux.nix')
-rw-r--r--programs/tmux.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/programs/tmux.nix b/programs/tmux.nix
deleted file mode 100644
index 6673b5d..0000000
--- a/programs/tmux.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ pkgs, ... }:
-{
- programs.tmux = {
- enable = true;
- terminal = "tmux-256color";
- historyLimit = 10000;
- plugins = with pkgs.tmuxPlugins;
- [
- catppuccin
- vim-tmux-navigator
- sensible
- yank
- ];
- shell = "${pkgs.zsh}/bin/zsh";
- extraConfig = ''
-set-option -sa terminal-overrides ",xterm*:Tc"
-set -g mouse on
-
-unbind C-b
-set -g prefix C-Space
-bind C-Space send-prefix
-
-bind -n M-H previous-window
-bind -n M-L next-window
-
-set -g base-index 1
-set -g pane-base-index 1
-set-window-option -g pane-base-index 1
-set-option -g renumber-windows on
-
-bind-key -T copy-mode-vi v send-keys -X begin-selection
-bind-key -T copy-mode-vi C-v send-keys -X rectangle-toggle
-bind-key -T copy-mode-vi y send-keys -X copy-selection-and-cancel
-
-bind '"' split-window -v -c ''${pane_current_path}"
-bind % split-window -h -c ''${pane_current_path}"
- '';
- };
-}