summaryrefslogtreecommitdiffstats
path: root/programs/zsh.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
commit4abb25ea7d3876899e641a8a16281203bd164d53 (patch)
tree8b47a0381776df3eb441cd6f31b15341d99847da /programs/zsh.nix
downloadnix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.gz
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.bz2
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.zip
initial config for all 3 systems
Diffstat (limited to 'programs/zsh.nix')
-rw-r--r--programs/zsh.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/programs/zsh.nix b/programs/zsh.nix
new file mode 100644
index 0000000..8d8fc91
--- /dev/null
+++ b/programs/zsh.nix
@@ -0,0 +1,23 @@
+{ config, pkgs, ... }:
+{
+ programs.zsh = {
+ enable = true;
+ shellAliases = {
+ ll = "ls -l";
+ unixos = "sudo nixos-rebuild switch --flake /etc/nixos";
+ uhome = "home-manager switch --flake /etc/nixos";
+ };
+ history = {
+ size = 10000;
+ path = "${config.xdg.dataHome}/zsh/history";
+ ignoreDups = true;
+ };
+
+ oh-my-zsh = {
+ enable = true;
+ plugins = [ "git" "thefuck" "pass" ];
+ theme = "dst";
+ };
+ syntaxHighlighting.enable = true;
+ };
+}