summaryrefslogtreecommitdiffstats
path: root/systems/bluetooth.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:57:37 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:57:37 -0400
commit58eee0458fe2c6976a3982c5b9a3e4919f13adcb (patch)
treedd427e5e4d1d791696421a60b23537a6c32c8083 /systems/bluetooth.nix
parentf4e995cebe8c9530a16db01b8385eadb1cab405c (diff)
downloadnix-config-58eee0458fe2c6976a3982c5b9a3e4919f13adcb.tar.gz
nix-config-58eee0458fe2c6976a3982c5b9a3e4919f13adcb.tar.bz2
nix-config-58eee0458fe2c6976a3982c5b9a3e4919f13adcb.zip
move bluetooth into generic config. add bluetooth support for headphones
Diffstat (limited to 'systems/bluetooth.nix')
-rw-r--r--systems/bluetooth.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/systems/bluetooth.nix b/systems/bluetooth.nix
new file mode 100644
index 0000000..d8eb230
--- /dev/null
+++ b/systems/bluetooth.nix
@@ -0,0 +1,16 @@
+{ inputs, outputs, config, hostname, username, lib, pkgs, stateVersion, ... }:
+{
+ hardware.bluetooth.enable = true;
+ services.blueman.enable = true;
+
+ environment.etc = {
+ "wireplumber/bluetooth.lua.d/51-bluez-config.lua".text = ''
+bluez_monitor.properties = {
+ ["bluez5.enable-sbc-xq"] = true,
+ ["bluez5.enable-msbc"] = true,
+ ["bluez5.enable-hw-volume"] = true,
+ ["bluez5.headset-roles"] = "[ hsp_hs hsp_ag hfp_hf hfp_ag ]"
+}
+ '';
+ };
+}