summaryrefslogtreecommitdiffstats
path: root/systems/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-10-14 10:53:18 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-10-14 10:53:18 -0400
commit5897af1a6c355f77c78f342d1d6f070670d14a4c (patch)
treeceacea8620f7a4f5b684837f8019244933286864 /systems/default.nix
parent972bff32235bbd414cbbaba5ac3eeb7979c2bad6 (diff)
downloadnix-config-5897af1a6c355f77c78f342d1d6f070670d14a4c.tar.gz
nix-config-5897af1a6c355f77c78f342d1d6f070670d14a4c.tar.bz2
nix-config-5897af1a6c355f77c78f342d1d6f070670d14a4c.zip
remove redundant system folder. add useful programs.
Diffstat (limited to 'systems/default.nix')
-rw-r--r--systems/default.nix75
1 files changed, 0 insertions, 75 deletions
diff --git a/systems/default.nix b/systems/default.nix
deleted file mode 100644
index 4f796dd..0000000
--- a/systems/default.nix
+++ /dev/null
@@ -1,75 +0,0 @@
-# Edit this configuration file to define what should be installed on
-# your system. Help is available in the configuration.nix(5) man page
-# and in the NixOS manual (accessible by running ‘nixos-help’).
-
-{ inputs, outputs, config, hostname, username, lib, pkgs, stateVersion, ... }:
-
-{
- imports =
- [
- ./${hostname}
- ../users/jon.nix
- ../programs/openvpn.nix
- ];
-
- services.pipewire = {
- enable = true;
- alsa.enable = true;
- alsa.support32Bit = true;
- pulse.enable = true;
- };
-
- #Default packages for QOL
- environment.systemPackages = with pkgs; [
- binutils
- clang-tools
- gcc
- gnutar
- gnumake
- gdb
- unzip
- wget
- ];
- programs.zsh.enable = true;
- users.defaultUserShell = pkgs.zsh;
- programs.neovim = {
- enable = true;
- defaultEditor = true;
- };
-
- #MPD
- services.mpd = {
- enable = true;
- musicDirectory = "/var/mus";
- extraConfig = ''
-audio_output {
- type "alsa"
- name "My ALSA"
- mixer_type "hardware"
- mixer_device "device"
- mixer_control "PCM"
-}
- '';
- network.listenAddress = "any";
- };
-
- #GPG
- programs.gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
- };
-
- # Open ports in the firewall.
- # networking.firewall.allowedTCPPorts = [ ... ];
- # networking.firewall.allowedUDPPorts = [ ... ];
- # Or disable the firewall altogether.
- # networking.firewall.enable = false;
-
- # This value determines the NixOS release from which the default
- # settings for stateful data, like file locations and database versions
- # on your system were taken. It‘s perfectly fine and recommended to leave
- # this value at the release version of the first install of this system.
- # Before changing this value read the documentation for this option
- # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
-
-}