summaryrefslogtreecommitdiffstats
path: root/systems/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-27 20:04:34 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-27 20:04:34 -0400
commitbcb39f3a7016f5f15696390210721dc7608b9617 (patch)
tree73ba0e9dc17fc51c49960ff28b04861d284914c8 /systems/default.nix
parentfb8d2e44a70a2e585d9da9f0a1cfe1d2c9a7b902 (diff)
downloadnix-config-bcb39f3a7016f5f15696390210721dc7608b9617.tar.gz
nix-config-bcb39f3a7016f5f15696390210721dc7608b9617.tar.bz2
nix-config-bcb39f3a7016f5f15696390210721dc7608b9617.zip
awesome: redo topbar.
reworking systems org
Diffstat (limited to 'systems/default.nix')
-rw-r--r--systems/default.nix69
1 files changed, 23 insertions, 46 deletions
diff --git a/systems/default.nix b/systems/default.nix
index 1cd1037..94bb592 100644
--- a/systems/default.nix
+++ b/systems/default.nix
@@ -12,11 +12,13 @@
../programs/openvpn.nix
];
+ #Default boot parameters.
boot = {
tmp.cleanOnBoot = true;
initrd.verbose = false;
};
+ #Nix package manager configs.
nix = {
registry = lib.mapAttrs (_: value: {flake = value;}) inputs;
@@ -30,17 +32,19 @@
gc = {
automatic = true;
dates = "weekly";
- options = "--delete-older-than 7d"
+ options = "--delete-older-than 7d";
};
};
+ #Networking
networking.hostName = hostname; # Define your hostname.
networking.useDHCP = lib.mkDefault true;
networking.networkmanager.enable = true;
- # Set your time zone.
+ #Timezone
time.timeZone = "America/New_York";
+ #Locale & Fonts
i18n.defaultLocale = "en_US.UTF-8";
i18n.extraLocaleSettings = {
LC_ADDRESS = "en_US.UTF-8";
@@ -53,27 +57,17 @@
LC_TELEPHONE = "en_US.UTF-8";
LC_TIME = "en_US.UTF-8";
};
-
- # Configure X11
- services.xserver = {
- enable = true;
- layout = "us";
- xkbVariant = "";
-
- displayManager = {
- sddm.enable = true;
- defaultSession = "none+awesome";
- };
-
- windowManager.awesome = {
- enable = true;
- luaModules = with pkgs.luaPackages; [
- luarocks
- luadbi-mysql
- ];
- };
- };
-
+ fonts.packages = with pkgs; [
+ fira-code
+ fira-code-symbols
+ font-awesome
+ liberation_ttf
+ noto-fonts
+ noto-fonts-cjk
+ noto-fonts-emoji
+ (nerdfonts.override { fonts = [ "FiraCode" ]; } )
+ ];
+
services.pipewire = {
enable = true;
alsa.enable = true;
@@ -81,12 +75,12 @@
pulse.enable = true;
};
+ #Security
security.rtkit.enable = true;
+ security.polkit.enable = true;
- # List packages installed in system profile. To search, run:
- # $ nix search wget
+ #Default packages for QOL
environment.systemPackages = with pkgs; [
- arandr
binutils
clang-tools
gcc
@@ -96,26 +90,14 @@
unzip
wget
];
-
- fonts.packages = with pkgs; [
- fira-code
- fira-code-symbols
- font-awesome
- liberation_ttf
- noto-fonts
- noto-fonts-cjk
- noto-fonts-emoji
- (nerdfonts.override { fonts = [ "FiraCode" ]; } )
- ];
-
programs.zsh.enable = true;
users.defaultUserShell = pkgs.zsh;
-
programs.neovim = {
enable = true;
defaultEditor = true;
};
+ #MPD
services.mpd = {
enable = true;
musicDirectory = "/var/mus";
@@ -131,19 +113,14 @@ audio_output {
network.listenAddress = "any";
};
- # Some programs need SUID wrappers, can be configured further or are
- # started in user sessions.
- # programs.mtr.enable = true;
+ #GPG
programs.gnupg.agent = {
enable = true;
enableSSHSupport = true;
};
- # List services that you want to enable:
-
- # Enable the OpenSSH daemon.
+ #SSH
services.openssh.enable = true;
-
environment.shellInit = ''
gpg-connect-agent /bye
export SSH_AUTH_SOCK=$(gpgconf --list-dirs agent-ssh-socket)