summaryrefslogtreecommitdiffstats
path: root/systems/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-29 14:22:24 -0400
commitf819e30b03dffcf9e74af4b8552e4a8ab8f54c58 (patch)
treec05f4f1db738d6cd9d2824b5000c6afc3b1d61d1 /systems/default.nix
parentd3bb6cbb4724bc8f18f72fa3fea3e65f73ae8d09 (diff)
downloadnix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.gz
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.tar.bz2
nix-config-f819e30b03dffcf9e74af4b8552e4a8ab8f54c58.zip
major reorganizing to seperate modules
Diffstat (limited to 'systems/default.nix')
-rw-r--r--systems/default.nix68
1 files changed, 0 insertions, 68 deletions
diff --git a/systems/default.nix b/systems/default.nix
index 94bb592..4f796dd 100644
--- a/systems/default.nix
+++ b/systems/default.nix
@@ -11,62 +11,6 @@
../users/jon.nix
../programs/openvpn.nix
];
-
- #Default boot parameters.
- boot = {
- tmp.cleanOnBoot = true;
- initrd.verbose = false;
- };
-
- #Nix package manager configs.
- nix = {
- registry = lib.mapAttrs (_: value: {flake = value;}) inputs;
-
- nixPath = lib.mapAttrsToList (key: value: "${key}=${value.to.path}") config.nix.registry;
-
- settings = {
- experimental-features = "nix-command flakes";
- auto-optimise-store = true;
- };
-
- gc = {
- automatic = true;
- dates = "weekly";
- options = "--delete-older-than 7d";
- };
- };
-
- #Networking
- networking.hostName = hostname; # Define your hostname.
- networking.useDHCP = lib.mkDefault true;
- networking.networkmanager.enable = true;
-
- #Timezone
- time.timeZone = "America/New_York";
-
- #Locale & Fonts
- i18n.defaultLocale = "en_US.UTF-8";
- i18n.extraLocaleSettings = {
- LC_ADDRESS = "en_US.UTF-8";
- LC_IDENTIFICATION = "en_US.UTF-8";
- LC_MEASUREMENT = "en_US.UTF-8";
- LC_MONETARY = "en_US.UTF-8";
- LC_NAME = "en_US.UTF-8";
- LC_NUMERIC = "en_US.UTF-8";
- LC_PAPER = "en_US.UTF-8";
- LC_TELEPHONE = "en_US.UTF-8";
- LC_TIME = "en_US.UTF-8";
- };
- fonts.packages = with pkgs; [
- fira-code
- fira-code-symbols
- font-awesome
- liberation_ttf
- noto-fonts
- noto-fonts-cjk
- noto-fonts-emoji
- (nerdfonts.override { fonts = [ "FiraCode" ]; } )
- ];
services.pipewire = {
enable = true;
@@ -75,10 +19,6 @@
pulse.enable = true;
};
- #Security
- security.rtkit.enable = true;
- security.polkit.enable = true;
-
#Default packages for QOL
environment.systemPackages = with pkgs; [
binutils
@@ -119,13 +59,6 @@ audio_output {
enableSSHSupport = true;
};
- #SSH
- services.openssh.enable = true;
- environment.shellInit = ''
-gpg-connect-agent /bye
-export SSH_AUTH_SOCK=$(gpgconf --list-dirs agent-ssh-socket)
- '';
-
# Open ports in the firewall.
# networking.firewall.allowedTCPPorts = [ ... ];
# networking.firewall.allowedUDPPorts = [ ... ];
@@ -138,6 +71,5 @@ export SSH_AUTH_SOCK=$(gpgconf --list-dirs agent-ssh-socket)
# this value at the release version of the first install of this system.
# Before changing this value read the documentation for this option
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
- system.stateVersion = stateVersion; # Did you read the comment?
}