summaryrefslogtreecommitdiffstats
path: root/systems/jonbox/filesystem.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
commit4abb25ea7d3876899e641a8a16281203bd164d53 (patch)
tree8b47a0381776df3eb441cd6f31b15341d99847da /systems/jonbox/filesystem.nix
downloadnix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.gz
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.bz2
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.zip
initial config for all 3 systems
Diffstat (limited to 'systems/jonbox/filesystem.nix')
-rw-r--r--systems/jonbox/filesystem.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/systems/jonbox/filesystem.nix b/systems/jonbox/filesystem.nix
new file mode 100644
index 0000000..30dafc6
--- /dev/null
+++ b/systems/jonbox/filesystem.nix
@@ -0,0 +1,18 @@
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/83cafaff-8be3-477f-b13c-c47dafdf969d";
+ fsType = "btrfs";
+ options = [ "subvol=@" ];
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/40EA-5550";
+ fsType = "vfat";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/acfc7ea5-0787-4e05-bcf1-20b7adb0f35c"; }
+ ];
+}