summaryrefslogtreecommitdiffstats
path: root/systems/jontest/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
commit4abb25ea7d3876899e641a8a16281203bd164d53 (patch)
tree8b47a0381776df3eb441cd6f31b15341d99847da /systems/jontest/default.nix
downloadnix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.gz
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.bz2
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.zip
initial config for all 3 systems
Diffstat (limited to 'systems/jontest/default.nix')
-rw-r--r--systems/jontest/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/systems/jontest/default.nix b/systems/jontest/default.nix
new file mode 100644
index 0000000..b2a7f82
--- /dev/null
+++ b/systems/jontest/default.nix
@@ -0,0 +1,22 @@
+{ lib, modulesPath, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ (modulesPath + "/profiles/qemu-guest.nix")
+ ./filesystem.nix
+ ];
+
+ boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "virtio_pci" "virtio_scsi" "sr_mod" "virtio_blk" ];
+ boot.kernelPackages = pkgs.linuxPackages_latest;
+
+ # Bootloader.
+ boot.loader.grub.enable = true;
+ boot.loader.grub.device = "/dev/vda";
+ boot.loader.grub.useOSProber = true;
+
+ services.qemuGuest.enable = true;
+ services.spice-vdagentd.enable = true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+}