summaryrefslogtreecommitdiffstats
path: root/systems/jontop/default.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
commit4abb25ea7d3876899e641a8a16281203bd164d53 (patch)
tree8b47a0381776df3eb441cd6f31b15341d99847da /systems/jontop/default.nix
downloadnix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.gz
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.bz2
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.zip
initial config for all 3 systems
Diffstat (limited to 'systems/jontop/default.nix')
-rw-r--r--systems/jontop/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/systems/jontop/default.nix b/systems/jontop/default.nix
new file mode 100644
index 0000000..1ce9aaf
--- /dev/null
+++ b/systems/jontop/default.nix
@@ -0,0 +1,30 @@
+{ inputs, config, lib, modulesPath, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ (modulesPath + "/installer/scan/not-detected.nix")
+ inputs.nixos-hardware.nixosModules.lenovo-thinkpad-x220
+ ./filesystem.nix
+ ];
+
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
+ boot.initrd.kernelModules = [ "i915" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ hardware.opengl = {
+ enable = true;
+ };
+
+ hardware.bluetooth.enable = true;
+ services.blueman.enable = true;
+
+ programs.light.enable = true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}