summaryrefslogtreecommitdiffstats
path: root/hosts/jonbox/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/jonbox/hardware.nix')
-rw-r--r--hosts/jonbox/hardware.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/hosts/jonbox/hardware.nix b/hosts/jonbox/hardware.nix
index ce734fe..bbe651f 100644
--- a/hosts/jonbox/hardware.nix
+++ b/hosts/jonbox/hardware.nix
@@ -12,7 +12,7 @@
fileSystems."/" =
{ device = "/dev/disk/by-uuid/83cafaff-8be3-477f-b13c-c47dafdf969d";
fsType = "btrfs";
- options = [ "subvol=@" ];
+ options = [ "compress=zstd" "subvol=@" ];
};
fileSystems."/boot" =
@@ -42,15 +42,20 @@
#SSD-optimization
services.fstrim.enable = true;
+ services.btrfs.autoScrub =
+ {
+ enable = true;
+ interval = "weekly";
+ };
#Hardware
hardware.nvidia = {
modesetting.enable = true;
powerManagement.enable = false;
powerManagement.finegrained = false;
- open = true;
+ open = false;
nvidiaSettings = true;
- package = config.boot.kernelPackages.nvidiaPackages.stable;
+ package = config.boot.kernelPackages.nvidiaPackages.beta;
};
#Firmware