summaryrefslogtreecommitdiffstats
path: root/hosts/jontop/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/jontop/default.nix')
-rw-r--r--hosts/jontop/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/hosts/jontop/default.nix b/hosts/jontop/default.nix
new file mode 100644
index 0000000..4e53279
--- /dev/null
+++ b/hosts/jontop/default.nix
@@ -0,0 +1,32 @@
+{ inputs, config, lib, modulesPath, pkgs, ... }:
+
+{
+ imports = [
+ ./hardware.nix
+ ../../modules/hardware/bluetooth.nix
+ ];
+
+ #Boot options
+ boot = {
+ loader = {
+ systemd-boot = {
+ enable = true;
+ configurationLimit = 8;
+ };
+ efi.canTouchEfiVariables = true;
+ timeout = 5;
+ };
+ kernelPackages = pkgs.linuxPackages_latest;
+ };
+
+
+ hardware.opengl = {
+ enable = true;
+ };
+
+ programs.light.enable = true;
+
+ awesome.enable = true;
+ mullvad-vpn.enable = true;
+}
+