summaryrefslogtreecommitdiffstats
path: root/hosts/jontop/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/jontop/default.nix')
-rw-r--r--hosts/jontop/default.nix76
1 files changed, 51 insertions, 25 deletions
diff --git a/hosts/jontop/default.nix b/hosts/jontop/default.nix
index c916696..cebdb90 100644
--- a/hosts/jontop/default.nix
+++ b/hosts/jontop/default.nix
@@ -1,31 +1,57 @@
-{ inputs, config, lib, modulesPath, pkgs, ... }:
-
{
- imports = [
- ./hardware.nix
- ../../modules/hardware/bluetooth.nix
- ];
+ inputs,
+ lib,
+ pkgs,
+ ...
+}: {
+ #Filesystems
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/72e455f9-4b10-4cb2-a8e4-cfe39c4a8d1f";
+ fsType = "btrfs";
+ options = [ "compress=zstd" "subvol=@" ];
+ };
- #Boot options
- boot = {
- loader = {
- systemd-boot = {
- enable = true;
- configurationLimit = 8;
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/27F7-4AFD";
+ fsType = "vfat";
+ };
+
+ swapDevices =
+ [
+ { device = "/dev/disk/by-uuid/4133a381-ab7d-4a25-9013-3f4b2d31bc5a"; }
+ ];
+
+ #Fonts
+ fonts.packages = with pkgs; [
+ fira-code
+ fira-code-symbols
+ font-awesome
+ liberation_ttf
+ noto-fonts
+ noto-fonts-cjk
+ noto-fonts-emoji
+ (nerdfonts.override { fonts = [ "FiraCode" ]; } )
+ ];
+
+ modules = {
+ device = {
+ cpu = "intel";
+ gpu = "intel";
+ drive = "ssd";
+ hasBluetooth = true;
+ };
+ desktop = {
+ hyprland.enable = true;
+ apps = {
+ browsers.firefox.enable = true;
+ games = {
+ enable = false;
+ steam.enable = false;
+ };
+ mpd.enable = false;
+ flatpak.enable = true;
+ newsboat.enable = true;
};
- efi.canTouchEfiVariables = true;
- timeout = 5;
};
- kernelPackages = pkgs.linuxPackages_latest;
- };
-
-
- hardware.opengl = {
- enable = true;
};
-
- programs.light.enable = true;
-
- awesome.enable = true;
}
-