summaryrefslogtreecommitdiffstats
path: root/hosts/jontop/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/jontop/hardware.nix')
-rw-r--r--hosts/jontop/hardware.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/hosts/jontop/hardware.nix b/hosts/jontop/hardware.nix
deleted file mode 100644
index dc5af7e..0000000
--- a/hosts/jontop/hardware.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ config, lib, pkgs, nixos-hardware, modulesPath, ... }:
-{
- imports =
- [
- (modulesPath + "/installer/scan/not-detected.nix")
- nixos-hardware.nixosModules.lenovo-thinkpad-x220
- ];
-
- boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
- boot.initrd.kernelModules = [ "i915" ];
- boot.kernelModules = [ "kvm-intel" ];
- boot.extraModulePackages = [ ];
-
- fileSystems."/" =
- { device = "/dev/disk/by-uuid/72e455f9-4b10-4cb2-a8e4-cfe39c4a8d1f";
- fsType = "btrfs";
- };
-
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/27F7-4AFD";
- fsType = "vfat";
- };
-
- swapDevices =
- [ { device = "/dev/disk/by-uuid/4133a381-ab7d-4a25-9013-3f4b2d31bc5a"; }
- ];
-
- #SSD-optimization
- services.fstrim.enable = true;
-
- #Firmware
- nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
- powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
- hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-
- #Networking
- networking.hostName = "jontop";
- networking.useDHCP = lib.mkDefault true;
- networking.networkmanager.enable = true;
-}