summaryrefslogtreecommitdiffstats
path: root/modules/hardware/audio.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/audio.nix')
-rw-r--r--modules/hardware/audio.nix22
1 files changed, 9 insertions, 13 deletions
diff --git a/modules/hardware/audio.nix b/modules/hardware/audio.nix
index 3ffa32a..a674597 100644
--- a/modules/hardware/audio.nix
+++ b/modules/hardware/audio.nix
@@ -23,22 +23,18 @@ in {
alsa.enable = true;
alsa.support32Bit = true;
pulse.enable = true;
+
+ wireplumber.extraConfig.bluetoothEnhancements = {
+ "monitor.bluez.properties" = {
+ "bluez5.enable-sbc-xq" = true;
+ "bluez5.enable-msbc" = true;
+ "bluez5.enable-hw-volume" = true;
+ };
+ };
};
user.extraGroups = ["audio"];
home.packages = [pkgs.pavucontrol];
- }
- (lib.mkIf (device.hasBluetooth) {
- home.configFile = {
- "wireplumber/bluetooth.lua.d/51-bluez-config.lua".text = ''
- bluez_monitor.properties = {
- ["bluez5.enable-sbc-xq"] = true,
- ["bluez5.enable-msbc"] = true,
- ["bluez5.enable-hw-volume"] = true,
- ["bluez5.headset-roles"] = "[ hsp_hs hsp_ag hfp_hf hfp_ag ]"
- }
- '';
- };
- })
+ }
]);
}