summaryrefslogtreecommitdiffstats
path: root/modules/hardware/bluetooth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/bluetooth.nix')
-rw-r--r--modules/hardware/bluetooth.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/hardware/bluetooth.nix b/modules/hardware/bluetooth.nix
new file mode 100644
index 0000000..1465d68
--- /dev/null
+++ b/modules/hardware/bluetooth.nix
@@ -0,0 +1,16 @@
+{ config, lib, pkgs, ... }:
+{
+ hardware.bluetooth.enable = true;
+ services.blueman.enable = true;
+
+ environment.etc = {
+ "wireplumber/bluetooth.lua.d/51-bluez-config.lua".text = ''
+bluez_monitor.properties = {
+ ["bluez5.enable-sbc-xq"] = true,
+ ["bluez5.enable-msbc"] = true,
+ ["bluez5.enable-hw-volume"] = true,
+ ["bluez5.headset-roles"] = "[ hsp_hs hsp_ag hfp_hf hfp_ag ]"
+}
+ '';
+ };
+}