summaryrefslogtreecommitdiffstats
path: root/modules/music/mpd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/music/mpd.nix')
-rw-r--r--modules/music/mpd.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/modules/music/mpd.nix b/modules/music/mpd.nix
deleted file mode 100644
index 8ee1f1b..0000000
--- a/modules/music/mpd.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ config, lib, pkgs, user, ... }:
-with lib;
-let
-
-in
-{
- options = {
- mpd = {
- enable = mkOption {
- type = types.bool;
- default = false;
- };
- };
- };
-
- config.home-manager.users.${user} = mkIf (config.mpd.enable)
- {
- services.mpd = {
- enable = true;
- musicDirectory = "/home/${user}/mus";
- extraConfig = ''
-audio_output {
- type "pipewire"
- name "Pipewire Output"
-}
- '';
- };
-
- home.packages = with pkgs; [
- mpc-cli
- ncmpcpp
- ];
- };
-}