summaryrefslogtreecommitdiffstats
path: root/modules/security.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/security.nix')
-rw-r--r--modules/security.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/security.nix b/modules/security.nix
new file mode 100644
index 0000000..c88fe0c
--- /dev/null
+++ b/modules/security.nix
@@ -0,0 +1,28 @@
+{
+ config,
+ options,
+ lib,
+ pkgs,
+ ...
+}: let
+
+in {
+ config = {
+ security.polkit.enable = true;
+ services.pcscd.enable = true;
+
+ programs.gnupg.agent = {
+ enable = true;
+ enableSSHSupport = true;
+ };
+
+ environment.systemPackages = [
+ pkgs.pinentry-curses
+ ];
+
+ home.packages = [
+ (pkgs.pass.withExtensions (exts: [exts.pass-otp ]))
+ pkgs.pinentry-qt
+ ];
+ };
+}