summaryrefslogtreecommitdiffstats
path: root/modules/shell/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/shell/zsh.nix')
-rw-r--r--modules/shell/zsh.nix56
1 files changed, 56 insertions, 0 deletions
diff --git a/modules/shell/zsh.nix b/modules/shell/zsh.nix
new file mode 100644
index 0000000..c39ec7a
--- /dev/null
+++ b/modules/shell/zsh.nix
@@ -0,0 +1,56 @@
+{
+ config,
+ options,
+ lib,
+ pkgs,
+ ...
+}: let
+ zshConfig = config.modules.shell.zsh;
+in {
+ options.modules.shell.zsh = {
+ enable = lib.mkOption {
+ type = lib.types.bool;
+ default = true;
+ };
+ };
+
+ config = lib.mkIf (zshConfig.enable) {
+ programs.zsh.enable = true;
+ users.defaultUserShell = pkgs.zsh;
+ environment.sessionVariables.SHELL = "${pkgs.zsh}/bin/zsh";
+ environment.pathsToLink = ["/share/zsh"];
+
+ home.packages = [
+ pkgs.zsh-autocomplete
+ pkgs.pure-prompt
+
+ pkgs.wget
+ pkgs.curl
+
+ pkgs.htop
+ pkgs.btop
+ ];
+
+ home.manager.programs = {
+ direnv = {
+ enable = true;
+ enableZshIntegration = true;
+ nix-direnv.enable = true;
+ };
+ zsh = {
+ enable = true;
+ enableAutosuggestions = true;
+ enableCompletion = true;
+ syntaxHighlighting.enable = true;
+ autocd = true;
+ defaultKeymap = "viins";
+ dotDir = ".config/zsh";
+
+ history = {
+ size = 10000;
+ ignoreDups = true;
+ };
+ };
+ };
+ };
+}