summaryrefslogtreecommitdiffstats
path: root/modules/terminal/kitty/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/terminal/kitty/default.nix')
-rw-r--r--modules/terminal/kitty/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/modules/terminal/kitty/default.nix b/modules/terminal/kitty/default.nix
new file mode 100644
index 0000000..1ff0b78
--- /dev/null
+++ b/modules/terminal/kitty/default.nix
@@ -0,0 +1,35 @@
+{ config, lib, pkgs, user, ... }:
+with lib;
+{
+ config.home-manager.users.${user} = mkIf (config.xserver.enable)
+ {
+ xdg.configFile."kitty/theme.conf".source = ./themes/mocha.conf;
+
+ programs.kitty = {
+ enable = true;
+ font = {
+ name = "FiraCode Nerd Font";
+ size = 12;
+ };
+ settings = {
+ repaint_delay = 10;
+ input_delay = 3;
+ sync_to_monitor = true;
+
+ remember_window_size = false;
+ initial_window_width = 640;
+ initial_window_height = 480;
+ enabled_layouts = "*";
+
+ tab_bar_min_tabs = 2;
+ tab_bar_edge = "bottom";
+ tab_bar_style = "powerline";
+ tab_powerline_style = "slanted";
+ tab_title_template = "{title}{' :{}'.format(num_windows) if num_windows > 1 else ''}";
+ };
+ extraConfig = ''
+ include ./theme.conf
+ '';
+ };
+ };
+}