summaryrefslogtreecommitdiffstats
path: root/programs/kitty.nix
diff options
context:
space:
mode:
Diffstat (limited to 'programs/kitty.nix')
-rw-r--r--programs/kitty.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/programs/kitty.nix b/programs/kitty.nix
deleted file mode 100644
index ca535a7..0000000
--- a/programs/kitty.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ pkgs, ... }:
-{
- xdg.configFile."kitty/theme.conf".source = ./dotfiles/kitty/themes/mocha.conf;
-
- programs.kitty = {
- enable = true;
- font = {
- name = "FiraCode Nerd Font";
- size = 12;
- };
- settings = {
- repaint_delay = 10;
- input_delay = 3;
- sync_to_monitor = true;
-
- remember_window_size = false;
- initial_window_width = 640;
- initial_window_height = 480;
- enabled_layouts = "*";
-
- tab_bar_min_tabs = 2;
- tab_bar_edge = "bottom";
- tab_bar_style = "powerline";
- tab_powerline_style = "slanted";
- tab_title_template = "{title}{' :{}'.format(num_windows) if num_windows > 1 else ''}";
- };
- extraConfig = ''
- include ./theme.conf
- '';
- };
-
-}