summaryrefslogtreecommitdiffstats
path: root/systems/bluetooth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/bluetooth.nix')
-rw-r--r--systems/bluetooth.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/systems/bluetooth.nix b/systems/bluetooth.nix
new file mode 100644
index 0000000..d8eb230
--- /dev/null
+++ b/systems/bluetooth.nix
@@ -0,0 +1,16 @@
+{ inputs, outputs, config, hostname, username, lib, pkgs, stateVersion, ... }:
+{
+ hardware.bluetooth.enable = true;
+ services.blueman.enable = true;
+
+ environment.etc = {
+ "wireplumber/bluetooth.lua.d/51-bluez-config.lua".text = ''
+bluez_monitor.properties = {
+ ["bluez5.enable-sbc-xq"] = true,
+ ["bluez5.enable-msbc"] = true,
+ ["bluez5.enable-hw-volume"] = true,
+ ["bluez5.headset-roles"] = "[ hsp_hs hsp_ag hfp_hf hfp_ag ]"
+}
+ '';
+ };
+}