summaryrefslogtreecommitdiffstats
path: root/systems/jontest/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/jontest/default.nix')
-rw-r--r--systems/jontest/default.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/systems/jontest/default.nix b/systems/jontest/default.nix
deleted file mode 100644
index b2a7f82..0000000
--- a/systems/jontest/default.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ lib, modulesPath, pkgs, ... }:
-
-{
- imports =
- [ # Include the results of the hardware scan.
- (modulesPath + "/profiles/qemu-guest.nix")
- ./filesystem.nix
- ];
-
- boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "virtio_pci" "virtio_scsi" "sr_mod" "virtio_blk" ];
- boot.kernelPackages = pkgs.linuxPackages_latest;
-
- # Bootloader.
- boot.loader.grub.enable = true;
- boot.loader.grub.device = "/dev/vda";
- boot.loader.grub.useOSProber = true;
-
- services.qemuGuest.enable = true;
- services.spice-vdagentd.enable = true;
-
- nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
-}