summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2024-09-30 12:01:07 -0400
committerJon Santmyer <jon@jonsantmyer.com>2024-09-30 12:01:07 -0400
commit63bd19127f66dda81007fcd0d8857e978740101f (patch)
tree781e971abde6f79b35b457927129066df42d955e /shell.nix
downloadsystemic-master.tar.gz
systemic-master.tar.bz2
systemic-master.zip
First commitHEADmaster
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..f2e5ae4
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,22 @@
+with import <nixpkgs> {};
+stdenv.mkDerivation {
+ name = "systemic-env";
+ nativeBuildInputs = [
+ rustc cargo
+
+ pkg-config
+ cmake
+
+ clang
+ stdenv.cc
+ stdenv.cc.libc stdenv.cc.libc_dev
+ glibc.static
+ ];
+
+ buildInputs = [
+ glfw
+ wayland.dev
+ ];
+
+ LIBCLANG_PATH = "${pkgs.llvmPackages.libclang.lib}/lib";
+}