summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..f2e5ae4
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,22 @@
+with import <nixpkgs> {};
+stdenv.mkDerivation {
+ name = "systemic-env";
+ nativeBuildInputs = [
+ rustc cargo
+
+ pkg-config
+ cmake
+
+ clang
+ stdenv.cc
+ stdenv.cc.libc stdenv.cc.libc_dev
+ glibc.static
+ ];
+
+ buildInputs = [
+ glfw
+ wayland.dev
+ ];
+
+ LIBCLANG_PATH = "${pkgs.llvmPackages.libclang.lib}/lib";
+}