summaryrefslogtreecommitdiffstats
path: root/hosts/jontop/hardware.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-29 20:38:26 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-29 20:38:26 -0400
commit1f327873451b9617e305b4b97f83a1824574881d (patch)
treed2b35b4fe800efb2b63ce1e99ea7a3bff0a184ec /hosts/jontop/hardware.nix
parentf819e30b03dffcf9e74af4b8552e4a8ab8f54c58 (diff)
downloadnix-config-1f327873451b9617e305b4b97f83a1824574881d.tar.gz
nix-config-1f327873451b9617e305b4b97f83a1824574881d.tar.bz2
nix-config-1f327873451b9617e305b4b97f83a1824574881d.zip
add laptop host
Diffstat (limited to 'hosts/jontop/hardware.nix')
-rw-r--r--hosts/jontop/hardware.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/hosts/jontop/hardware.nix b/hosts/jontop/hardware.nix
new file mode 100644
index 0000000..7d3f7c9
--- /dev/null
+++ b/hosts/jontop/hardware.nix
@@ -0,0 +1,37 @@
+{ ... }:
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix") ];
+
+ boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
+ boot.initrd.kernelModules = [ "i915" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/72e455f9-4b10-4cb2-a8e4-cfe39c4a8d1f";
+ fsType = "btrfs";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/27F7-4AFD";
+ fsType = "vfat";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/4133a381-ab7d-4a25-9013-3f4b2d31bc5a"; }
+ ];
+
+ #SSD-optimization
+ services.fstrim.enable = true;
+
+ #Firmware
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+
+ #Networking
+ networking.hostName = "jontop";
+ networking.useDHCP = lib.mkDefault true;
+ networking.networkmanager.enable = true;
+}