summaryrefslogtreecommitdiffstats
path: root/hosts/jontop/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/jontop/hardware.nix')
-rw-r--r--hosts/jontop/hardware.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/hosts/jontop/hardware.nix b/hosts/jontop/hardware.nix
new file mode 100644
index 0000000..7d3f7c9
--- /dev/null
+++ b/hosts/jontop/hardware.nix
@@ -0,0 +1,37 @@
+{ ... }:
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix") ];
+
+ boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
+ boot.initrd.kernelModules = [ "i915" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/72e455f9-4b10-4cb2-a8e4-cfe39c4a8d1f";
+ fsType = "btrfs";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/27F7-4AFD";
+ fsType = "vfat";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/4133a381-ab7d-4a25-9013-3f4b2d31bc5a"; }
+ ];
+
+ #SSD-optimization
+ services.fstrim.enable = true;
+
+ #Firmware
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+
+ #Networking
+ networking.hostName = "jontop";
+ networking.useDHCP = lib.mkDefault true;
+ networking.networkmanager.enable = true;
+}