summaryrefslogtreecommitdiffstats
path: root/housemaker.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-23 15:41:49 -0400
commit4abb25ea7d3876899e641a8a16281203bd164d53 (patch)
tree8b47a0381776df3eb441cd6f31b15341d99847da /housemaker.nix
downloadnix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.gz
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.tar.bz2
nix-config-4abb25ea7d3876899e641a8a16281203bd164d53.zip
initial config for all 3 systems
Diffstat (limited to 'housemaker.nix')
-rw-r--r--housemaker.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/housemaker.nix b/housemaker.nix
new file mode 100644
index 0000000..973507c
--- /dev/null
+++ b/housemaker.nix
@@ -0,0 +1,27 @@
+{ inputs, outputs, stateVersion, ... }:
+{
+ newhome = { nixpkgs, overlays, hostname, username, platform }: inputs.home-manager.lib.homeManagerConfiguration {
+ pkgs = inputs.nixpkgs.legacyPackages.${platform};
+ extraSpecialArgs = {
+ inherit inputs outputs hostname platform username stateVersion overlays;
+ };
+ modules = [
+ { nixpkgs.overlays = overlays; }
+ ./home/${username}/home.nix
+ ];
+ };
+
+ newhost = { nixpkgs, overlays, hostname, username }: inputs.nixpkgs.lib.nixosSystem {
+ specialArgs = {
+ inherit inputs outputs hostname username stateVersion overlays;
+ };
+ modules = [
+ { nixpkgs.overlays = overlays; }
+ ./systems
+ ];
+ };
+
+ forAllSystems = inputs.nixpkgs.lib.genAttrs [
+ "x86_64-linux"
+ ];
+}