summaryrefslogtreecommitdiffstats
path: root/housemaker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'housemaker.nix')
-rw-r--r--housemaker.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/housemaker.nix b/housemaker.nix
new file mode 100644
index 0000000..973507c
--- /dev/null
+++ b/housemaker.nix
@@ -0,0 +1,27 @@
+{ inputs, outputs, stateVersion, ... }:
+{
+ newhome = { nixpkgs, overlays, hostname, username, platform }: inputs.home-manager.lib.homeManagerConfiguration {
+ pkgs = inputs.nixpkgs.legacyPackages.${platform};
+ extraSpecialArgs = {
+ inherit inputs outputs hostname platform username stateVersion overlays;
+ };
+ modules = [
+ { nixpkgs.overlays = overlays; }
+ ./home/${username}/home.nix
+ ];
+ };
+
+ newhost = { nixpkgs, overlays, hostname, username }: inputs.nixpkgs.lib.nixosSystem {
+ specialArgs = {
+ inherit inputs outputs hostname username stateVersion overlays;
+ };
+ modules = [
+ { nixpkgs.overlays = overlays; }
+ ./systems
+ ];
+ };
+
+ forAllSystems = inputs.nixpkgs.lib.genAttrs [
+ "x86_64-linux"
+ ];
+}