summaryrefslogtreecommitdiffstats
path: root/modules/device.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2024-01-07 12:00:08 -0500
committerJon Santmyer <jon@jonsantmyer.com>2024-01-07 12:00:08 -0500
commit7b79203f54853733d4fae88943829d0e24e6e49f (patch)
treea352d199fad7453332b9308a6295164157729f27 /modules/device.nix
parent184bd30bcb303104a4981ac742d8f8961c5477e7 (diff)
downloadnix-config-7b79203f54853733d4fae88943829d0e24e6e49f.tar.gz
nix-config-7b79203f54853733d4fae88943829d0e24e6e49f.tar.bz2
nix-config-7b79203f54853733d4fae88943829d0e24e6e49f.zip
massive overhaul
Diffstat (limited to 'modules/device.nix')
-rw-r--r--modules/device.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/device.nix b/modules/device.nix
new file mode 100644
index 0000000..acf9eb5
--- /dev/null
+++ b/modules/device.nix
@@ -0,0 +1,16 @@
+{
+ config,
+ options,
+ lib,
+ ...
+}: {
+ options.modules.device = {
+ name = lib.mkOption {type = lib.types.str;};
+ cpu = lib.mkOption {type = lib.types.enum ["intel"];};
+ gpu = lib.mkOption {type = lib.types.enum ["intel" "nvidia"];};
+ drive = lib.mkOption {type = lib.types.enum ["ssd" "nvme"];};
+
+ hasBluetooth = lib.mkOption {type = lib.types.bool;};
+ displayProtocol = lib.mkOption {type = lib.types.enum ["xserver" "wayland"];};
+ };
+}