summaryrefslogtreecommitdiffstats
path: root/modules/device.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/device.nix')
-rw-r--r--modules/device.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/device.nix b/modules/device.nix
new file mode 100644
index 0000000..acf9eb5
--- /dev/null
+++ b/modules/device.nix
@@ -0,0 +1,16 @@
+{
+ config,
+ options,
+ lib,
+ ...
+}: {
+ options.modules.device = {
+ name = lib.mkOption {type = lib.types.str;};
+ cpu = lib.mkOption {type = lib.types.enum ["intel"];};
+ gpu = lib.mkOption {type = lib.types.enum ["intel" "nvidia"];};
+ drive = lib.mkOption {type = lib.types.enum ["ssd" "nvme"];};
+
+ hasBluetooth = lib.mkOption {type = lib.types.bool;};
+ displayProtocol = lib.mkOption {type = lib.types.enum ["xserver" "wayland"];};
+ };
+}