summaryrefslogtreecommitdiffstats
path: root/modules/shell/git.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2024-01-07 12:00:08 -0500
committerJon Santmyer <jon@jonsantmyer.com>2024-01-07 12:00:08 -0500
commit7b79203f54853733d4fae88943829d0e24e6e49f (patch)
treea352d199fad7453332b9308a6295164157729f27 /modules/shell/git.nix
parent184bd30bcb303104a4981ac742d8f8961c5477e7 (diff)
downloadnix-config-7b79203f54853733d4fae88943829d0e24e6e49f.tar.gz
nix-config-7b79203f54853733d4fae88943829d0e24e6e49f.tar.bz2
nix-config-7b79203f54853733d4fae88943829d0e24e6e49f.zip
massive overhaul
Diffstat (limited to 'modules/shell/git.nix')
-rw-r--r--modules/shell/git.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/shell/git.nix b/modules/shell/git.nix
new file mode 100644
index 0000000..d0835f5
--- /dev/null
+++ b/modules/shell/git.nix
@@ -0,0 +1,20 @@
+{
+ config,
+ options,
+ lib,
+ pkgs,
+ ...
+}: let
+ gitConfig = config.modules.shell.git;
+in {
+ options.modules.shell.git = {
+ enable = lib.mkOption {
+ type = lib.types.bool;
+ default = true;
+ };
+ };
+
+ config = lib.mkIf (gitConfig.enable) {
+ programs.git.enable = true;
+ };
+}