summaryrefslogtreecommitdiffstats
path: root/modules/shell/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/shell/git.nix')
-rw-r--r--modules/shell/git.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/shell/git.nix b/modules/shell/git.nix
new file mode 100644
index 0000000..d0835f5
--- /dev/null
+++ b/modules/shell/git.nix
@@ -0,0 +1,20 @@
+{
+ config,
+ options,
+ lib,
+ pkgs,
+ ...
+}: let
+ gitConfig = config.modules.shell.git;
+in {
+ options.modules.shell.git = {
+ enable = lib.mkOption {
+ type = lib.types.bool;
+ default = true;
+ };
+ };
+
+ config = lib.mkIf (gitConfig.enable) {
+ programs.git.enable = true;
+ };
+}