summaryrefslogtreecommitdiffstats
path: root/programs/zsh.nix
diff options
context:
space:
mode:
authorJon Santmyer <jon@jonsantmyer.com>2023-09-24 20:33:22 -0400
committerJon Santmyer <jon@jonsantmyer.com>2023-09-24 20:33:22 -0400
commitb28259b353c3ee2d51a7cbdf0e90136ae846b68d (patch)
treeaf4fb1c41b6fa346b9a55832228645f4dd4d68fe /programs/zsh.nix
parent59328d463daf5c7af066e284c7f9072e8da02f1f (diff)
downloadnix-config-b28259b353c3ee2d51a7cbdf0e90136ae846b68d.tar.gz
nix-config-b28259b353c3ee2d51a7cbdf0e90136ae846b68d.tar.bz2
nix-config-b28259b353c3ee2d51a7cbdf0e90136ae846b68d.zip
add watchfile script
Diffstat (limited to 'programs/zsh.nix')
-rw-r--r--programs/zsh.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/programs/zsh.nix b/programs/zsh.nix
index 8d8fc91..03a096f 100644
--- a/programs/zsh.nix
+++ b/programs/zsh.nix
@@ -1,11 +1,16 @@
{ config, pkgs, ... }:
{
+ home.packages = with pkgs; [
+ inotify-tools
+ ];
+
programs.zsh = {
enable = true;
shellAliases = {
ll = "ls -l";
unixos = "sudo nixos-rebuild switch --flake /etc/nixos";
uhome = "home-manager switch --flake /etc/nixos";
+ watchfile = "/etc/nixos/programs/scripts/watchfile.sh ";
};
history = {
size = 10000;