summaryrefslogtreecommitdiffstats
path: root/programs/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'programs/zsh.nix')
-rw-r--r--programs/zsh.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/programs/zsh.nix b/programs/zsh.nix
index 8d8fc91..03a096f 100644
--- a/programs/zsh.nix
+++ b/programs/zsh.nix
@@ -1,11 +1,16 @@
{ config, pkgs, ... }:
{
+ home.packages = with pkgs; [
+ inotify-tools
+ ];
+
programs.zsh = {
enable = true;
shellAliases = {
ll = "ls -l";
unixos = "sudo nixos-rebuild switch --flake /etc/nixos";
uhome = "home-manager switch --flake /etc/nixos";
+ watchfile = "/etc/nixos/programs/scripts/watchfile.sh ";
};
history = {
size = 10000;